# \[教程\] 在青云上搭建自己的Unblock Youku服务器

**URL:** <https://bbs.uku.im/t/topic/29>\
**Category:** 技术讨论\
**Created:** [2016 年4 月 30 日 15:35 UTC](https://bbs.uku.im/t/topic/29 "2016-04-30T15:35:06Z")\
**Posts on this page:** 20\
**Page:** 2

<div class="post-metadata">

作者： ![nick\_feng](https://avatars.discourse-cdn.com/v4/letter/n/ccd318/32.png) [@nick\_feng](https://bbs.uku.im/u/nick_feng)\
发布日期： [2016 年8 月 29 日 02:54 UTC](https://bbs.uku.im/t/topic/29/21 "2016-08-29T02:54:26Z")

</div>

如果有国内vps了，  
1.搭个ss应该也可以解除限制吧？  
2.那跟用squid设置有什么区别？  
3.看了在美团云、青云上面搭建的教程。。但美团云最后不用上传pac到文件服务器？pac文件要上传到哪里？国外的vps可以么？  
😂小白问题多。。见谅

---

<div class="post-metadata">

作者： ![cs\_tommy](https://avatars.discourse-cdn.com/v4/letter/c/e79b87/32.png) [@cs\_tommy](https://bbs.uku.im/u/cs_tommy)\
发布日期： [2016 年8 月 29 日 06:29 UTC](https://bbs.uku.im/t/topic/29/22 "2016-08-29T06:29:41Z")

</div>

1. 搭建ss也可以解决这个问题，毕竟ss也是一种代理方式，但请注意的是，请不要把ss和squid同时安装在一个vps上面，因为曾经有用户反馈过即便使用的是不同端口也会冲突，可能两者会相互干扰。
2. squid在这里的作用其实跟ss一样，都是作为代理链的一个中转。不同的是，ss是一个socks 5代理，而且具备数据混淆能力防止数据被嗅探，但squid不具备这个能力。但其实使用起来两者没有大的区别
3. pac文件其实也是要自己手动修改的，除非你有别的办法可以同步官方版本的pac列表并把里面的代理地址修改为自己的地址。由于代理信息都是在pac文件里面，所以放哪里都没有问题，包括国外的vps，只要那个地址是可以直接访问的就可以了。

---

<div class="post-metadata">

作者： ![nick\_feng](https://avatars.discourse-cdn.com/v4/letter/n/ccd318/32.png) [@nick\_feng](https://bbs.uku.im/u/nick_feng)\
发布日期： [2016 年8 月 29 日 11:15 UTC](https://bbs.uku.im/t/topic/29/23 "2016-08-29T11:15:11Z")

</div>

懂了。。感谢详细回覆:+1:👍👍👍

---

<div class="post-metadata">

作者： ![beatFeTiger](https://avatars.discourse-cdn.com/v4/letter/b/e47774/32.png) [@beatFeTiger](https://bbs.uku.im/u/beatFeTiger)\
发布日期： [2016 年9 月 24 日 13:55 UTC](https://bbs.uku.im/t/topic/29/24 "2016-09-24T13:55:39Z")

</div>

请教大神，按照您的教程美团云上的服务器搭建完成，PAC文件在电脑上和IPAD上均测试成功。小米盒子上请问应该如何配置自己的代理服务器呢？盒子已经ROOT过，装了CHINATUNNEL, 因为代理服务器不够稳定，因此想自己配置一个解决。

但是小米盒子上不知道该怎么配置了，设置了登录账户密码，可以访问，但是无法播放应该解锁的视频。应该是PAC文件没有GET到的原因吧。

请指点一二。

---

<div class="post-metadata">

作者： ![jelly](https://avatars.discourse-cdn.com/v4/letter/j/a87d85/32.png) [@jelly](https://bbs.uku.im/u/jelly)\
发布日期： [2016 年10 月 20 日 09:20 UTC](https://bbs.uku.im/t/topic/29/25 "2016-10-20T09:20:11Z")

</div>

你好，请问你的 “配置PAC文件” 到底是什么意思，那个任意服务器是什么意思？楼主能不能说清楚一点？？  
感谢感谢！！

---

<div class="post-metadata">

作者： ![jelly](https://avatars.discourse-cdn.com/v4/letter/j/a87d85/32.png) [@jelly](https://bbs.uku.im/u/jelly)\
发布日期： [2016 年10 月 20 日 09:37 UTC](https://bbs.uku.im/t/topic/29/26 "2016-10-20T09:37:32Z")

</div>

> [@beatFeTiger](#):
>
> PAC文件在电脑上

请问你放在电脑上，是放在具体哪个地方？？？谢谢

---

<div class="post-metadata">

作者： ![beatFeTiger](https://avatars.discourse-cdn.com/v4/letter/b/e47774/32.png) [@beatFeTiger](https://bbs.uku.im/u/beatFeTiger)\
发布日期： [2016 年10 月 21 日 00:17 UTC](https://bbs.uku.im/t/topic/29/27 "2016-10-21T00:17:56Z")

</div>

教程里面写的其实很清楚了，pac文件修改以后上传到任意服务器，得到一个网址，后缀为pac，也就是你可以访问到的地方。chrome里打开unblock设置改为自己的pac地址就OK。

---

<div class="post-metadata">

作者： ![jelly](https://avatars.discourse-cdn.com/v4/letter/j/a87d85/32.png) [@jelly](https://bbs.uku.im/u/jelly)\
发布日期： [2016 年10 月 21 日 01:33 UTC](https://bbs.uku.im/t/topic/29/28 "2016-10-21T01:33:25Z")

</div>

你好，谢谢你的回答，但是我还是知道pac文件怎么放置。我目前的状况是局域网里两台机子，一台centos的，已经安装好了squid，另一台是我的wind7机子，现在我想测试我的win7机子来连接centos的unblock youku服务器，但是这个pac文件我就是不知道放哪儿？放在centos上还是win7上，具体放在哪儿？？请指教，谢谢

---

<div class="post-metadata">

作者： ![cs\_tommy](https://avatars.discourse-cdn.com/v4/letter/c/e79b87/32.png) [@cs\_tommy](https://bbs.uku.im/u/cs_tommy)\
发布日期： [2016 年10 月 21 日 02:18 UTC](https://bbs.uku.im/t/topic/29/29 "2016-10-21T02:18:04Z")

</div>

放哪里都可以，无论是云端还是本地，只要你的win7机子可以访问到那个pac文件即可，不过记得改pac文件里面的代理地址(一定是外网地址，不能是局域网内网IP)

---

<div class="post-metadata">

作者： ![jelly](https://avatars.discourse-cdn.com/v4/letter/j/a87d85/32.png) [@jelly](https://bbs.uku.im/u/jelly)\
发布日期： [2016 年10 月 21 日 02:27 UTC](https://bbs.uku.im/t/topic/29/30 "2016-10-21T02:27:07Z")

</div>

谢谢，如果我放在win7本机上，chrome在哪儿设置路径才能访问到pac文件呢？

---

<div class="post-metadata">

作者： ![jelly](https://avatars.discourse-cdn.com/v4/letter/j/a87d85/32.png) [@jelly](https://bbs.uku.im/u/jelly)\
发布日期： [2016 年10 月 21 日 02:45 UTC](https://bbs.uku.im/t/topic/29/31 "2016-10-21T02:45:59Z")

</div>

![](https://bbs-uku-uploads.s3-ap-northeast-1.amazonaws.com/original/1X/dae878e06dea74a9a7e4cd415f467304463229f9.png)

我还有个疑问，如图，我配置unblock youku插件的时候他是直接连接的公网IP和端口号，跟这个pac文件怎么感觉毫无联系呢，就是感觉这个pac文件都不会用到啊？？本人小白，求指导

---

<div class="post-metadata">

作者： ![cs\_tommy](https://avatars.discourse-cdn.com/v4/letter/c/e79b87/32.png) [@cs\_tommy](https://bbs.uku.im/u/cs_tommy)\
发布日期： [2016 年10 月 21 日 03:21 UTC](https://bbs.uku.im/t/topic/29/32 "2016-10-21T03:21:28Z")

</div>

用chrome插件的话本来就不用pac啊，pac是给移动设备或者火狐浏览器用的。

---

<div class="post-metadata">

作者： ![jelly](https://avatars.discourse-cdn.com/v4/letter/j/a87d85/32.png) [@jelly](https://bbs.uku.im/u/jelly)\
发布日期： [2016 年10 月 21 日 05:03 UTC](https://bbs.uku.im/t/topic/29/33 "2016-10-21T05:03:37Z")

</div>

谢谢，谢谢，明白了！

---

<div class="post-metadata">

作者： ![wood2464](https://avatars.discourse-cdn.com/v4/letter/w/c5a1d2/32.png) [@wood2464](https://bbs.uku.im/u/wood2464)\
发布日期： [2017 年7 月 3 日 04:43 UTC](https://bbs.uku.im/t/topic/29/34 "2017-07-03T04:43:26Z")

</div>

请问这个方法还可以用么？  
我自己弄了个阿里云ecs  
然后卡在了  
curl -o /opt/crx\_url\_list.txt [http://pac.uku.im/regex](http://pac.uku.im/regex) 这步  
他说cannot connect to host.

然后用了WinSCP 手动添加了crx\_url\_list 跟squid config之后  
squid 启动失败

代码是这样的…  
[root@iZ2zeeqkw1f8693bfw2ozuZ ~]# service squid start  
Starting squid: [FAILED]  
2017/07/03 12:27:43| Processing Configuration File: /etc/squid/squid.conf (depth 0)  
2017/07/03 12:27:43| Processing: acl crx\_url url\_regex -i "/opt/crx\_url\_list.txt"  
2017/07/03 12:27:43| Processing: acl localnet src 10.0.0.0/8 # RFC1918 possible internal network  
2017/07/03 12:27:43| Processing: acl localnet src 172.16.0.0/12 # RFC1918 possible internal network  
2017/07/03 12:27:43| Processing: acl localnet src 192.168.0.0/16 # RFC1918 possible internal network  
2017/07/03 12:27:43| Processing: acl localnet src fc00::/7 # RFC 4193 local private network range  
2017/07/03 12:27:43| aclIpParseIpData: IPv6 has not been enabled.  
2017/07/03 12:27:43| Processing: acl localnet src fe80::/10 # RFC 4291 link-local (directly plugge d) machines  
2017/07/03 12:27:43| aclIpParseIpData: IPv6 has not been enabled.  
2017/07/03 12:27:43| Processing: acl SSL\_ports port 443  
2017/07/03 12:27:43| Processing: acl Safe\_ports port 80 # http  
2017/07/03 12:27:43| Processing: acl Safe\_ports port 443 # https  
2017/07/03 12:27:43| Processing: acl Safe\_ports port 1025-65535 # unregistered ports  
2017/07/03 12:27:43| Processing: acl CONNECT method CONNECT  
2017/07/03 12:27:43| Processing: http\_access deny !Safe\_ports  
2017/07/03 12:27:43| Processing: http\_access deny CONNECT !SSL\_ports  
2017/07/03 12:27:43| Processing: http\_access deny manager  
2017/07/03 12:27:43| aclParseAclList: ACL name ‘manager’ not found.  
FATAL: Bungled squid.conf line 14: http\_access deny manager  
Squid Cache (Version 3.1.23): Terminated abnormally.  
CPU Usage: 0.008 seconds = 0.007 user + 0.001 sys  
Maximum Resident Size: 30240 KB  
Page faults with physical i/o: 0

谢谢啦

---

<div class="post-metadata">

作者： ![cs\_tommy](https://avatars.discourse-cdn.com/v4/letter/c/e79b87/32.png) [@cs\_tommy](https://bbs.uku.im/u/cs_tommy)\
发布日期： [2017 年7 月 3 日 04:45 UTC](https://bbs.uku.im/t/topic/29/35 "2017-07-03T04:45:55Z")

</div>

如果你是阿里的话，我建议你用github的教程

---

<div class="post-metadata">

作者： ![wood2464](https://avatars.discourse-cdn.com/v4/letter/w/c5a1d2/32.png) [@wood2464](https://bbs.uku.im/u/wood2464)\
发布日期： [2017 年7 月 5 日 00:34 UTC](https://bbs.uku.im/t/topic/29/36 "2017-07-05T00:34:02Z")

</div>

> [@cs\_tommy](#):
>
> github

请问有链接么… 没搜到啊

---

<div class="post-metadata">

作者： ![mc16888](https://avatars.discourse-cdn.com/v4/letter/m/ac8455/32.png) [@mc16888](https://bbs.uku.im/u/mc16888)\
发布日期： [2017 年7 月 5 日 10:41 UTC](https://bbs.uku.im/t/topic/29/37 "2017-07-05T10:41:57Z")

</div>

here

在美团云架设自己的 Unblock Youku 代理服务器

```
https://github.com/uku/Unblock-Youku/wiki/_pages
```

---

<div class="post-metadata">

作者： ![wood2464](https://avatars.discourse-cdn.com/v4/letter/w/c5a1d2/32.png) [@wood2464](https://bbs.uku.im/u/wood2464)\
发布日期： [2017 年7 月 6 日 00:16 UTC](https://bbs.uku.im/t/topic/29/38 "2017-07-06T00:16:21Z")

</div>

这个我看了  
可还是会无法解决我遇见的问题  
curl -o /opt/crx\_url\_list.txt [http://pac.uku.im/regex](http://pac.uku.im/regex)  
就是这个无法连接啊ToT

---

<div class="post-metadata">

作者： ![Zhengyu\_Meng](https://avatars.discourse-cdn.com/v4/letter/z/7feea3/32.png) [@Zhengyu\_Meng](https://bbs.uku.im/u/Zhengyu_Meng)\
发布日期： [2017 年7 月 29 日 02:38 UTC](https://bbs.uku.im/t/topic/29/39 "2017-07-29T02:38:33Z")

</div>

我也遇到过无法连接的问题 。用的是阿里云。  
后来我把list下载下来，放到别的服务器上解决的。

---

<div class="post-metadata">

作者： ![wood2464](https://avatars.discourse-cdn.com/v4/letter/w/c5a1d2/32.png) [@wood2464](https://bbs.uku.im/u/wood2464)\
发布日期： [2017 年7 月 30 日 07:10 UTC](https://bbs.uku.im/t/topic/29/40 "2017-07-30T07:10:20Z")

</div>

放到别的服务器？

[上一页](https://bbs.uku.im/t/topic/29.md?page=1)

[下一页](https://bbs.uku.im/t/topic/29.md?page=3)
